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Opening, Creating, and Saving a Project and 

Logging In to SkylineGlobe Server 
TerraExplorer basic commands are available from the File menu  located in the upper-left 
corner of the application.  

Opening an Existing Project  

Click  > Open > Open Project from File OR Open Project from SkylineGlobe > Browse to an existing .Fly file or 

connect to a SG server. You can open a US demo project by clicking the link on the Start page. 

Saving a Project as a FLY File  

A .Fly file is a compressed binary file that contains all the project settings and content, and pointers to terrain 

databases (MPT) or other loaded files. Click  and then click Save or Save As… 

Creating a New Project  

Click  and then click New > In dialog, browse to required terrain database (MPT), and click OK > Define 

project settings. 

Logging In to a SkylineGlobe Server 

On the top right of the application ribbon, click Log in > In SkylineGlobe Server dialog box enter login information and 

click Log in. 

More about: Basic concepts in TerraExplorer > 

 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Start_Page.htm
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Navigating in the 3D Window 
Navigate through the 3D World in the way you find most natural and intuitive: navigate freely using 
on-screen navigation controls or any of the three mouse modes, or fly to predefined locations or 
objects. 

Viewing or Flying to a Location or Object (Using the Project Tree)  

1. In the Project Tree, double-click the location or object, or right-click and select Fly to, Jump to, or View. If you view 

the object, you can select one of the pre-defined flight patterns that compass about the object.  

2. To stop a flight to a location right-click in 3D Window, and select Stop or press the Spacebar. 

Free Flight  

Using the mouse to navigate: 

In Drag mode, do the following: 

Note: This is the default mode. Other navigation modes can be set in the Options dialog. 

• To pan - Click and drag the mouse to the sides, forward, or backward.  

• To zoom in and out - Roll the middle mouse wheel. 

• To change direction and tilt - Click and drag the middle mouse wheel. 

Using HUD navigation controls: 

View tab > Select Graphic HUD to display. 

 Turn the plane to face North.  

 Zoom in.  

 Zoom out. 

 

Underground Navigation  

1. Home tab > Underground Mode.  

2. Navigate in the 3D environment. You can freely go through the terrain surface in any direction. 

Following a Dynamic Object  

• In the Project Tree > Double-click the required dynamic object. 

More about: Navigating in the 3D World > 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Navigating.htm
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Managing Projects - Using the Project Tree 
The Project Tree provides a list of elements in the terrain that can be sorted and arranged into groups. 
Using this list, you control the appearance of information in the 3D Window. The Omni search tool at the 
top of the Project Tree enables you to search everything (Project Tree, ribbon commands, SkylineGlobe 
Server and addresses server) in one-click for the commands, layers, objects and locations you need.  

Searching the Project Tree, Ribbon Commands, Address Server, and 

SkylineGlobe Server  

In the Project Tree, Search here field, type a search term. When clicking on a 

search result, the operation TE performs depends on the result type 

selected:  

• Commands: - Activates the command.  

• Project: - Selects the item on the project tree and flies to its location.  

• Addresses: - Flies to the address location.  

• SkylineGlobe: - Loads the layer.  

• [Feature Layer]: - Flies to the feature location. 

Showing and Hiding Objects or Layers in the 3D Window  

In Project Tree, click the object or layer’s show/ hide icon  to display or 

hide it in the 3D Window. 

Selecting a Tree Item  

In Project Tree, click the item. Double-clicking performs the activation action 

(fly to, jump to, circle/ oval pattern, etc.) set in the item’s property sheet. 

Creating and Working with Groups  

1. Right-click blank area (root) of Project Tree (for subgroup, right-click 

parent group) > Select Create Group.  

2. Type the name of the new group and press ENTER.  

3. To move an item into a new group, click and drag it onto a group folder. 

4. To add a new element to a group, right-click group > Point to New > 

Select Location, Presentation or Message. 

5. To set group properties, right click <group> > Properties. In property sheet, set parameters. 

Creating Locations in the Current Camera Position 

1. In the Project Tree, right-click > New > Location. Type a name for the location and click. 

2. Open property sheet to set activation action or add a message: In Project Tree, right-click location > Properties. 

More about: Using the Project Tree > 

System Requirements 
System requirements for installing and using TerraExplorer: 
 
• Operating System - Windows® 10 /11 – 64 bit. 

• System Memory - 2GB of RAM (4 GB or more recommended). 

• Video Card – 1 GB of video memory (2 GB or more recommended).  

• Processor - 4 cores (8 cores recommended). 

• Browser - Microsoft Internet Explorer 11 or higher. 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_the_Project_Tree.htm
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Basic Project Settings 
Project Settings, including general settings, terrain parameters, flight model, and application layout 
are saved in the .Fly file and applied each time this file is used. 

To open Settings dialog: Home tab > Click Project Settings > Click required tab.  

Environment Tab 

• Select a Sky Color. 

• Select Sky Texture and Clouds Map to apply.  

Terrain Database Tab 

• Select the local or remote Terrain (MPT) Database currently used by this project. 

• Enter the Number of Terrain Imaginary (resolution) Levels that are used to enhance the visual quality when the 

camera is close to the ground. 

• Set the project’s Terrain Coordinate System. 

Date and Light Tab 

• Select the Use Sunlight option button if you want the sun to serve as the light source 

for the project.  

• Select a range for the Date and Time Slider.  

General Tab 

Set basic parameters for the .Fly file, including startup message parameters:  

• Click Set as Home to set the current camera location as the default startup position for this .Fly file.  

• Click Add Message to determine the message to be shown when the project is opened.  

• Click Wait to set the number of seconds TerraExplorer waits at the beginning of the session before starting the 

Auto-Start procedure or allowing manual flight.  

More about: Using project settings > 

Controlling Date and Time 
When the sun is used as a project’s light source, displayed light on the terrain corresponds to the 
date/ time selected on the Time Slider. Project data containing timespan tags displays on the 
terrain according to the timespan set. 

1. View tab > Select Time Slider. The Time Slider displays in the 3D 

Window. Drag the blue marker and yellow arrow  together to the 

required date and time on the slider. If you want to display data whose 

timespans fall anywhere in a time range, drag the blue marker to the 

start point of the time range and the yellow arrow to the endpoint of the 

time range  

2. Click Date and Time Settings icon  to the right of the slider to select a time zone, and time slider range. (When a 

one-year range is selected, two sliders display, one for the date, and one for the time of day). 

Note: Project startup settings for the date and time can be set in the Date and Light tab in the Project Settings 

dialog box and are saved in the .Fly file. Any date and time settings made using the Date and Time Settings 

icon are not saved to the .Fly. 

More about: Setting data and time > 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_the_Project_Settings.htm
https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Using_Screen_Overlay.htm?rhhlterm=date%20%E2%80%9Cdate%20time%20slider%20sliders&rhsearch=date%20and%20time%20slider


 

5 

Analysis Tools 
TerraExplorer measurement and terrain analysis tools deliver extensive topographical and strategic 
information, enabling a more accurate geospatial understanding of the terrain. 

Measurement, Line of Sight and Shadow Tools 

 

 

Aerial / Horizontal / Vertical Distance 

1. Analysis tab > Distance. Select which distance lines to display. 

2. To snap the points to another edge, object, or vertex, click XYZ Snap Magnet 

. 

3. Click any point in the terrain or on an object to define the start point and 

other segments. Right-click to finish. 

 

 

Terrain Area (and Perimeter)  

1. Analysis tab > Area > Click Horizontal Plane Area  or 3D Plane Area . 

2. Click to define start point. Drag to additional points and click to define a 

region. Right-click to finish.  

3. To calculate surface area, enter Terrain surface sample interval, and click 

Terrain Surface Area .  

4. to set the measurement points based on the mouse and snap the point to 

another edge, object, or vertex, click XYZ Snap Magnet . 

 

Line of Sight - Indicates whether specific locations in the 3D World can be 

seen (green line) from a selected position or not (red). 

1. Analysis tab > Click Line of Sight. 

2. In property sheet, set parameters > In 3D Window, click to define observer 

viewpoint, then click additional times for targets. Right click to finish.  

 

3D Viewshed - Create a 3D viewshed on buildings/ models and bare terrain.  

1. Analysis tab > Viewshed > Click 3D Viewshed. 

2. In 3D Window, click to define your viewpoint for the 3D viewshed, and then 

click again to define your desired endpoint. 

3. In property sheet, set parameters such as visible/hidden area color and 

viewshed Distance and FOV. 

 

Viewshed Query - Analyze the visibility from multiple viewshed observer 

viewpoints to a selected area. 

1. Analysis tab > Viewshed > Select 3D Viewshed Query. 

2. In the dialog box, set the Query parameter defining which viewsheds are 

analyzed, and all other parameters. 

3. Select a method of designating the area for the viewshed query (Follow Line, 

Fill Area, Selected Group, From Clipboard, or Viewshed Area). 
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Viewshed on Route - Represent the view from a series of points (route).  

1. Analysis tab > Click Viewshed on Route > Select any of the following: 

• 3D Viewshed on Route By Speed/ 3D Viewshed on Route By Time - 

Animated representation of visible terrain/ objects as object moves on 

defined route based on set speed/ over set time frame. 

• 3D Viewshed on Route Query - Analyzes the visibility of a selected area 

from multiple viewshed observer viewpoints along a route.  

2. Click in 3D Window to mark route’s waypoints. Right-click to finish.  

 

Threat Dome - Indicates the volume visible from a given point on the terrain. 

1. Analysis tab > Click Threat Dome. 

2. In property sheet, set parameters  including the output type > In 3D Window, 

click to define pivot point. 

 

Shadow/Selection Shadow – Cast a shadow from all buildings and 3D models or 

only for selected objects. 

Global shadow: 

• Analysis tab > Shadow  

Selection shadow:  

1. Select the objects from which to cast a shadow. 

2. Analysis tab > Selection Shadow > Click Show Selection Shadow. 

 

Shadow Query - Calculate and graphically represent overall shadow coverage or 

a particular object’s shadow effect in a specified area. 

1. Analysis tab > Click Shadow Query. 

2. Set the Query parameter defining which objects’ shadows are queried.  

3. Select a method of designating the area for the shadow query (Follow Line, Fill 

Area, Selected Group, or From Clipboard). 

More about: Measurement, line of sight, and shadow tools > 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Measurement_Tools.htm
https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Line_of_Sight_Tools.htm
https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Shadow_Tools.htm
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Terrain Analysis Tools 

 

Slope Map - Apply palette colors (slope degree) & slope arrows (slope direction). 
1. Analysis tab > Click the arrow next to Slope Map and select either: 

• Global Slope Map - Applies default slope map to entire terrain and 3DML 

• Custom Slope Map - Advanced slope map with customizable parameters 

(e.g. coverage area, palette): select: Slope Colors/Slope Dir./Both 

2. For Custom Slope Map, in property sheet, set Coverage Area and Palette.  

3. If you selected Rectangle Coverage Area, click in 3D Window to add opposite 

corners of the coverage rectangle. 

 

Contour Map - Apply palette colors to each elevation level and connect points of 
equal elevation with contour lines.  
1. Analysis tab > Click the arrow next to Contour Map and select either: 

• Global Contour Map - Applies contour map to entire terrain and 3DML. 

• Custom Contour Map Object - Advanced map, customizable parameters. 

2. For Custom Contour Map, in property sheet, set Coverage Area, Palette, etc.  

3. If Coverage Area set to Rectangle, click in 3D Window to draw rectangle. 

 

Flood Tool - Calculate land covered by flooding. 
1. Analysis tab > Click Flood. 

2. In property sheet, set single instance of water level rising or continuous and 

related parameters. 

3. In 3D Window, click center of coverage area, and drag mouse to required 

radius size and click. 

 

Volume Tool - Analyzes volume of terrain/model modified by Modify Terrain/ 
3DML objects or volume difference between elevation layer & base terrain.  
1. Analysis tab > Click Volume. 

2. Compare field > Select an analysis mode. 

3. Perform the steps relevant to the selected mode: 

• Modify Terrain - Draw New: Click Create Modify > In 3D Window, draw 

polygon. 

• Modify Terrain - Select Existing: Select a modify object & click Start Calculation. 

• Elevation Layer: Mark your area of interest by drawing area or in location 

of all polygon clipboard objects.  

 

Best Path - Calculate best path without exceeding definable climb and descent 
slope limits.  
1. Analysis tab > Click Best Path. 

2. In property sheet, set parameters > In 3D Window, click to define start and 

endpoint. 

 

Terrain Profile - Display terrain elevation profile along a defined path, and 
related information (e.g., maximum/ minimum elevation values, slope).  
1. Analysis tab > Click Terrain Profile. 

2. Select profile mode: Normal - Display profile for selected polyline(s) OR 

Compare - Compare polyline's profile to specified elevation layer’s. 

3. If you selected Compare mode, select elevation layer for comparison. 

4. Select methods of designating the polyline(s) for terrain profile: 

a Follow Line - Terrain profile created along line drawn in 3D Window.  

b Selected Group - Terrain profile created for polylines in selected group.  

c From Clipboard - Terrain profile created for polylines in clipboard.  

More about: Terrain analysis tools > 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Terrain_Analysis_Tools.htm
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Comparison Tools 

 

Swipe Snapshots - Create and compare snapshots showing different 
versions of the area in view in the 3D Window by showing or hiding objects 
in the Project Tree. 
1. Navigate to required area and click Analysis > Swipe > Swipe Snapshots. 

2. Show/hide objects in the Project Tree, and click Compare. 

3. Mode selection - Choose between 4 clipping modes and Transparency 

mode. 

4. Slider control - Define the clipping or transparency level extent. 

 

Swipe Mesh, Point Cloud, and Imagery - Compare 2 layers or a layer to base 
terrain by dynamically clipping or modifying transparency of overlaying layer.  
1. Zoom in on an area with a visible imagery layer. 

2. Analysis tab > Swipe > Swipe Layers. 

3. Click any of the following: 3D Mesh, Point Cloud, and Imagery to filter the 

selection to the layer type(s) you want. Click Refresh & Auto-Select to 

auto-detect layers in view. 

4. Model display style – Select mesh model display style if comparing mesh. 

5. Slider control - Define the clipping or transparency level extent. 

 

Elevation Comparison - Compare elevation of two elevation, feature, point 
cloud or mesh layers or between layer and base terrain.  
1. Analysis tab > Elevation > Select 3D Mesh, Point Cloud, Elevation or Feature. 

2. Select the layers from the two drop-down lists, and minimum elevation 

difference between the layers that should be marked. 

3. Mark area by drawing area polygon or from clipboard. 

4. Review analysis in results dialog and graphically represented by the 

generated point feature layer. 

 

Cross Section –Exposes obscured sections of the 3D View by making a 

horizontal or vertical straight cut. 

1. Analysis tab > Click Cross Section. 

2. Set the required settings (e.g. Transparency) and then click Start. 

3. In the 3D Window, click to create a cross section. Then use the Cross 

Section slider to adjust the position of the cross section plane.  

4. Click Stop to exit the particular cross section. 

 

Buffer Query – Scans for all 3D elements within a set buffer zone of a 

selected line and highlights them in the 3D Window. 

1. Analysis tab > Click Buffer Query. 

2. Set scan properties (e.g., buffer zone radius, scanning area).  

3. Select polylines for buffer query: From Clipboard or Selected Group. 

4. All query points in whose buffer zone 3D elements were found are colored 

in red. Click a red query point to highlight in red the 3D elements found. 

More about: Comparison tools > 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Comparison_Tools.htm
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Creating and Editing a Presentation 
Easily share your 3D visualization with others by creating a presentation that can be replayed, in 
which you combine a customized flight route with a particular display of the project. Presentations 
consist of a series of actions, which are organized into steps, to help you structure your 
presentation. Each action is added to the presentation from the “Create new action” dropdown list 
in the toolbar at the top of the Presentation Editor. 

Step 1: Create a flight route - Animate movement over the terrain by 

recording your navigation or by adding locations 

Open the Presentation Editor 

• Home tab > Presentation > in the presentation control panel, click Open 

Presentation Editor .  

Creating a Recorded Route 

1. Presentation Editor > Create New Action list > Record Route.  

2. Click Start Recording and then navigate freely in the 3D Window to any 

location or point of interest. 

3. Adjust zoom, tilt, etc.  

4. Presentation Editor top panel > Stop Recording. 

Creating a Locations Route 

1. Presentation Editor > Create New Action list > Fly to Location/Object Route. This adds the current location. 

2. To change the location, fly to the required location and then click Click to Use Current Position or drag and drop a 

location from the Project Tree into the Presentation Editor.. 

Step 2: Animate what is displayed on the terrain: 

• Determine what is visible on the terrain and in the 3D Window - Show or Hide: objects, groups, slope/contour 

map, shadows and messages. 

• Add captions 

• Set time and date 

• Launch a different presentation from the current one.  

In Presentation Editor > Create New Action list> Select an operation.  

Step 3: Edit the presentation  

Add Steps - "Chapter" Headings to Organize Presentation Actions 

1. Presentation Editor’s top toolbar > Create New Step . 

2. Type step name. Set Requires Click to True to require user click to 

advance. Drag presentation actions from one step to another to organize. 

Set Wait Times and Transitions 

1. Presentation Editor > drag actions/steps to reorder steps as required. 

2. In the Create New Action list, select Set Wait Time. Then enter the 

number of seconds to wait. 
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Step 4: View the presentation  

 In the Project Tree, double-click the required presentation. Use the control 

panel to start, stop, jump to previous/next action or step, and set time factor.  

 

More about: Presentations > 

Creating Movies 
Share your 3D visualization even with people who do not have TerraExplorer installed, by creating a 
movie in MP4 or AVI format from any presentation in your project.  

1. Create a presentation. 

2. Presentation Editor’s top toolbar > Create Movie . 

3. In Settings dialog, set size of each frame and whether to hide screen overlay. 

Basic Objects 
Add and edit graphic entities, each with its own styling properties. Objects include: labels, lines, 
polygons, 2D/ 3D shapes, 3D models, and buildings. Available objects depend on TerraExplorer 
license level. Objects can be organized in Project Tree groups. 

Creating an Object  

1. Objects tab > Click <required object>.  

2. Click and draw the object in the 3D Window. Right-click to finish. For 2D and 3D shapes, left-click to finish. 

Selecting an Object 

After selecting a single object, a yellow frame surrounds the object and the object’s property sheet opens. When selecting 

multiple objects, a yellow frame surrounds each of the selected objects and the Multi Edit property sheet opens. 

Selecting a Single Object  

• From Project Tree: In Project Tree, right-click object > from the shortcut menu, select Properties... OR 

• From 3D Window: On Home tab, click Select > In 3D Window, select object.  

Selecting Multiple Objects  

• From Project Tree: In Project Tree, select the required objects (Use SHIFT and CTRL to select sequential and non-

sequential tree items) > right-click > from the shortcut menu, select Properties. 

• From 3D Window: On Home tab, click Select > Press and hold the CTRL key > In 3D Window, select each of the 

objects you want > In 3D Window, right-click and select Properties.  

• From 3D Window (all objects in a selected area): On Home tab > Select > Area Selection > In 3D Window, draw area 

polygon by clicking (at least three points) and right-click to finish > In 3D Window, right-click and select Properties. 

 Working with Objects 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Presentations.htm
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Editing an Object 

1. Project Tree > Right-click object and select Properties.  

2. On the top of the property sheet, click  to edit the entire object. Then: 

•  To move the object. Drag to required location.  

•  To change the object’s altitude. Drag to required height. 

•  To move the object based on where the mouse is pointing (rather 

than according to XYZ offset).  

•  To set position based on mouse and snap the object to another 

object. Drag to required location. 

3. To edit object nodes (of polylines, 2D polygons, and 3D polygons), click . Then:  

•  To move a node. Then click required node and drag to new location.  

•  To change node’s altitude. Then click required node and drag to new height. 

•  To move a node based on where the mouse is pointing (rather than according to XYZ offset).  

•  To set position based on mouse and snap the object to another object. Then click required node and drag to 

required location. 

• To delete a node, point to the node, right-click, and select Delete Node. 

• To add a node, point to one of the object’s lines, and click anywhere a red node appears.  

4. Set properties such as color, altitude, timespan, tooltip, and texture in the 

object’s property sheet. 

Adding 3D Models  

1. Objects tab > Click 3D Model.  

2. In dialog, browse to the required file to load.  

3. In 3D Window, click mouse to define position of model’s pivot point on 

terrain. 

4. Adjust the model’s position and size in the 3D Window or from property 

sheet. See: “Editing an Object.”  

5. Using the property sheet, set the parameters of the 3D object.  

6. Drag any of the three arrow resizers in/ out to adjust any of the model’s 

dimensions. 

More about: Creating and editing objects > 

Working with Objects 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Creating_New_Objects.htm
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Advanced Objects 
Create advanced objects: e.g., dynamic objects, modify terrain objects, video, buildings, and 3D 
models. 

Creating and Editing Dynamic Objects 

1. Objects tab> Dynamic Objects group> Click <required object >. 

2. Property sheet > File Name field > Browse for a model file. 

3. In property sheet, set Motion Style and other properties. 

4. In 3D Window, click mouse to define waypoints. Right-click to finish. 

5. For editing, see: “Editing an Object.” Note that object nodes correspond to object’s route waypoints. 

Creating Buildings 

1. Objects tab > Click Building. 

2. In 3D Window, click the mouse to define roof polygon. Right-click to finish. 

3. If there is no horizontal offset between roof and base, right click to finish. If there is an offset, drag base to place 

and left-click.  

4. In property sheet, set building’s properties including height, texture, and roof style. 

Video on Terrain and Video Billboard 

Play a video file on an area of the terrain or on a floating billboard. 

1. Objects tab > Video on Terrain/ Video Billboard. 

2. Browse to a video file. For a streaming video, click Cancel, and in property sheet, type the URL. 

3. Set location of video:  

• In property sheet, set Use Telemetry File to No, and in 3D Window, click to define location. OR 

• In property sheet, set Use Telemetry File to Yes, and browse to file  

4. In property sheet, set projector properties and other video parameters. 

5. To play, pause, and stop video, right-click in Project Tree and select required option. 

 

More about: Dynamic and terrain objects > 

 

Working with Objects 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Dynamic_Objects.htm
https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Terrain_Objects.htm
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Working with Raster Layers 
Raster layers include imagery layers containing geo-referenced, satellite or aerial images that 
overlay the terrain imagery, and elevation layers containing geo-referenced elevation raster that 
replaces the elevation data of the terrain. 

Loading Raster Layers 

1. Home tab > Click Raster Layer > Select Elevation/ 

Imagery Layer from file or from server. 

2. In the dialog, browse to the required file, and click 

Open. 

3. If loading from server, select the required server, and 

click Select. In the dialog that displays, enter the 

information required for the selected server, and select 

the required layer. 

Note: If the source file is geo-referenced it is 

positioned accordingly on the terrain. 

Otherwise, it is placed at the center of the 3D 

Window. You can then manually edit its 

position, or reproject it. 

4. If the source file does not include coordinate system 

information or TerraExplorer cannot read it from the 

file, the Coordinate System dialog box opens. Specify 

the coordinate system of the layer. TerraExplorer then 

reprojects (converts) the layer data to the project’s 

coordinate system. Although the source file retains its 

original coordinate system, it is placed on the terrain according to the reprojection parameters.  

5. After the object has been placed on the terrain, you can change its properties using the property sheet. To clip a 

subsection of the raster, click the Draw button in the Imagery/ Elevation section of the property sheet. Place at 

least three polygon points in the 3D Window by clicking in the desired location. Finish by right-clicking. 

Creating Resolution Pyramids 

To enable the display of a layer at different altitudes, TerraExplorer requires a number of resolution levels per layer, also 

known as a resolution pyramid. If a layer does not have sufficient resolution levels, TerraExplorer can create them. 

1. In Project Tree, select layers that require a resolution pyramid. 

2. Layers tab > Click Raster to MPT.  

3. In dialog, select layers, and click Convert. 

More about: Raster layers > 

 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Raster_Layers.htm
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Working with Feature and 3DML Layers 

Loading Feature Layers 
A feature layer is a visual representation of a geographic data set using geographic features such as 
points, lines, and polygons. In contrast to objects, all the features in a layer share the same 
properties and behavior. These properties can be modified from the layer’s property sheet. 

1. Home tab > Click Feature layer. 

2. If loading from file, in dialog, browse to required file and click Open.  

3. If loading from server, select the server type, and click Connect. Fill in the required Connection parameters for the 

specific server or database, and click Connect.  

4. Select a layer from the Select Layer dialog box and click Next. 

5. Set the layer’s General Settings. Then click Next.  

6. If the layer’s coordinate system is different from the terrain’s, select the Reproject check box.  

7. Then click the Set Coordinate System button to open the Coordinate System dialog page to specify the coordinate 

system of the layer.  

8. Select Stream to retrieve layer information dynamically based on the camera’s position. 

9. Select Entire Layer to load the entire layer when the .Fly file opens.  

10. Select the Annotation Symbol check box to automatically add a point annotation object in the center of each layer 

feature.  

11. In the Predefined Visibility section, select the viewer altitude from which visibility distance and scale is set to 

optimum.  

12. Select the attribute fields to load. In the property sheet, set layer parameters, and apply different properties such 

as line color or cylinder height, based on the attribute field values of the objects.  
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Feature and 3DML Layer Operations 
Spatial operations on a layer’s features include: merging features into a single feature, clipping one 
polygon from another, exploding a multi-part feature into its individual component features, and 
exporting selected features to a new file. Feature layer operations are only enabled for 
TerraExplorer Pro users. Most operations are also available for 3DML layers. 

 

Selecting Features (Individual Selection) 

1. In Project Tree, select required layer. 

2. Select the individual features required: 

3. Layer Edit tab > Click Select Feature. 

4. In the 3D Window, select the required feature. (To select multiple features, press and hold the CTRL key) OR  

Selecting Features by Spatial Query 

1. Layer Edit tab > Click Spatial Query. Select Area (polygon), Line, Point or Object. 

2. In the Type dropdown list > Select Intersect to select all features whose geometry intersects at any point with the 

selection geometry. Select Completely Within to select only features whose entire geometry falls within the 

selection geometry.  

3. In the Buffer dropdown list, enter a buffer radius outside the selection.  

4. In the 3D Window, click to draw a polygon, line or point or select the required object for feature selection. 

Using the Attribute Table: Searching for Features and Editing Attributes 

1. In Project Tree, select required layer. Then Layer Edit tab > Attribute Table. 

2. In the Query builder section, enter an attribute, 

condition, and value and click Insert String.  

3. If you want to include additional strings in your 

search expression, click one of the connector 

buttons: (And, Or, ()) and repeat step 2 for the next 

condition. Then click Search.  

4. To display on the terrain only filtered features, click 

Operation > Select Show Exclusive.  

5. To create a new layer of filtered features, click 

Operation > Add as new layer entry. 

6. To save the selected features to a new shapefile or 

.Fly file, click Operation > Select Save As. 

7. To modify attribute properties, double-click the 

attribute value and modify as required.  



 

16 

Working with Feature and 3DML Layers 

Exporting Selected Features to a New File  

1. Select the required features. See: “Selecting Features.”  

2. Layer Edit tab > Click Export Layer > Select Save Selected Features As.  

3. In dialog, type a File name. Browse to the required Save location and click Save. 

Adding a Feature to a Layer  

1. Select the layer. Then Layer Edit tab > Click Add [Polyline, Point, or Polygon].  

2. In property sheet, set the parameters of the geographic feature. In 3D Window, place the object’s points. Right-

click to finish.  

Editing Features (Merge, Clip, Intersection, Explode)  

1. Select required features (Merge: Only polylines/ polygons, Intersection, Clipping: Only polygons). 

2. On the Layer Edit tab > Click Editing and select one of the following: 

• To merge features into one feature: select Merge > In 3D Window, click feature whose attributes should be 

used for merged object. 

• To clip: select Clip > In the 3D Window, click the polygon to clip from the other polygons. 

• To create new feature from intersection of features: select Intersection > In 3D Window, click polygon that will 

determine attributes.  

• To explode a multi-part feature into component features: Layer Edit tab > Click Editing > To explode all features: 

select Explode All. To separate out only specific features: select Explode. Then, in 3D Window, select features to 

separate out. 

Saving a Layer 

• On the Layer Edit tab, click Save Layer to save changes to original layer or Click Export Layer > Save As to save to a 

new file.  

 
 

More about: Feature layer operations >

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Working_with_Feature_Layers.htm


 

17 

Working with Feature and 3DML Layers 

Working with 3D Mesh Layers (3DML) 
Mesh layers are multi-resolution, textured mesh models that may include classification layers, as 
well as polygons from BIM datasets. They are created through automatic reconstruction methods, 
manual modeling, or building information modeling (BIM). Most mesh layers used in TerraExplorer 
are in Skyline’s proprietary, stream-optimized 3DML format. DAE, OSGB, and 3D Tiles mesh layers 
are automatically converted to 3DML upon import. 

Loading and Importing Mesh Layers 

1. Layers tab > Click Load 3D Mesh > Select any of the 

following: 

• 3D Mesh Layer from File – Then in dialog, browse 

to required file and click Open.  

• SkylineGlobe Server – Then search for the layer 

and click Load.  

• 3D Tile from URL – Then type the URL to the 3D 

Tile’s root file, and click Load. 

• Import DAE Layer – Browse to the 3D Mesh 

Model you want to import, and Output Folder. 

Select the polygon feature layers you want to 

use to classify areas of the mesh model. Click Create. 

• Import OSGB / 3D Tiles – Browse to the Input Mesh Layer you want to import, and Output Folder. Set the 

Input/Output Coordinate System if required. Click Create. 

2. After the layer has been placed on the terrain, you can change its properties using the property sheet, and use 

attribute information included in a BIM or any 3DML with feature layers to display only selected areas of the mesh 

model that match a specific attribute value or colorize the mesh model based on attribute value. 

 

Loading Building Information Modeling (BIM) Layers 

TerraExplorer reads FBX and IFC BIM files and converts them to the 3DML format for optimized viewing and streaming 

on desktop/ mobile applications, with full support for 

spatial & attribute queries.  

1. Layers tab > Click BIM.  

2. Click Add Files. Then browse to the required file, and 

click Open. 

3. Using the property sheet, set the BIM parameters as 

required. 

4. Click Import. 
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Classifying 3D Mesh Layers (3DML) 

Mesh layers are classified using polygon feature layers that enable you to visually distinguish different areas of the mesh 

layer, access the attribute data of the classification features and perform spatial and attribute queries on the feature 

layer that is classifying the mesh layer. 

The classification is dynamic, reflecting 

any changes to the polygon features, and 

requires no pre-processing.  

1. Load the required feature layer.  

2. In the layer's property sheet, set the 

Altitude Method to Relative to 

Terrain or Absolute, and set the 

Classification Mode. This mode 

determines how to display the 

classification polygon: Classify by 

colorizing all objects and layers 

contained within the extruded 

polygon or Classify by displaying a 3D 

polygon (based on the extruded 

polygon). 

3. Set the appearance, e.g., fill color, 

altitude, or visibility, of your 

classification polygons. Polygon properties can be based on layer attribute fields.  

 

Exporting Mesh Layers to Other Formats 

3DML can be exported to Cesium 3D Tiles and I3S formats. Export is supported for all mesh layers except for imported 

OGC 3D Tiles (B3DM) and 3DML created from models feature layers. 

1. Select the mesh layer, and then on the 3D Mesh Layer tab > Click Export Mesh.  

2. Select an Output Format: Skyline 3DML, 

Cesium 3D Tiles or Esri I3S, and an Output 

Folder. Click Add Files. Then browse to the 

required file, and click Open. 

3. Select the Output Coordinate System, and 

Reproject Elevation if required. 

4. Click Create. 

Exporting to Models 

Polygonal areas of a mesh layer, e.g., buildings, 

can also be exported to individual OBJ models. 

Export is supported for all mesh layers except for 

imported 3D Tiles and BIM, 3DML created from models feature layers, and 3DML from SGS that do not have edit 

permission. 

1. Select the mesh layer, and then on the 3D Mesh Layer tab > Click Export Mesh, and select way to define areas to 

export:  

• Export by All Classification Features   

• Export by Selected Features > Select required features in classification layer. 

• Export by External Feature Layers > In dialog, select layers. 

• Draw and Export Single Model > Draw polygon around required model. 

2. Browse to Output Folder, and click Create.

 

More about: Working with mesh layers > 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Working_with_3D_Mesh_Layers.htm
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Collaborating over the Network with Other 

TerraExplorer Users 
Connecting over the internet/intranet, multiple users can work 
together in the 3D environment: chat, annotate the terrain with 
text labels and free hand drawing, synchronize flight, and share 
content by dragging any object/layer to a shared folder. One 
user serves as the manager of the session, while the rest 
connect to the session as clients. 

The collaboration server can run on a local computer of one of the session 

members, or as part of an existing collaboration server (to enable better 

management and control and to solve security problems when accessing 

end-user computers behind firewalls).  

When a collaboration server is activated, using the Start Local Session request, 

it serves the current session on a local machine and after the termination of 

the session the server shuts down. When the collaboration server is set up as 

part of an existing collaboration server it is always up and running. 

Joining or Opening a Session  

1. Tools tab > Click Collaboration.  

2. Select a connection type: 

• Create local session - To start a communication server on your local computer, and serve as session manager/ leader.  

• Create session on server - To create a new session on a collaboration server of which you are the manager and 

leader. Then type the Server host name (name or IP address of the server). 

• Join session - To join an ongoing session opened by another user on a local computer or on a collaboration 

server. Then type the Server host name (name or IP address of the Manager’s local computer or the 

collaboration server). 

3. In the Choose Session Name field, type the session’s name. If you join an ongoing session, type the session name 

that was given by the manager. 

4. In the Choose User Name field, type a user name.  

5. If you started a local or a server session, from the On User Connection drop-down list, select whether to send the 

Fly project or link to users who join the session. 

6. Click the Start Session button to create the session or Join Session to join an ongoing session. A second 

Collaboration dialog box opens. 

Managing a Session 

If you created the session: 

• To appoint a different leader, in Participants list, select name > Click Set as Leader.  

• To send your camera position to other participants, select Broadcast location. 

If you joined a session: 

• To attach your 3D Window to leader’s view, select the Follow leader check box. Clear to navigate freely. 

• To invite participants to session, click Invite. Then in the Enter Email(s) field, type the e-mail address. Click Invite. 

•  Follow the instructions in the message body and send the mail.  

Collaborating with Other Session Participants 

You can chat, point, draw freehand, add and place text labels, and share content with other participants in the session. 

More about: Collaborating > 

Additional Capabilities 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/Collaboration_Tool.htm
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Loading .Fly and KML/ KMZ Files 
When another TerraExplorer project (.Fly layer) or KML/KMZ file is loaded in TerraExplorer, the 
geographic content is read and put in the Project Tree as a group. 

1. Home tab > Click Feature layer > Select .fly or kml/ kmz.  

2. In dialog, browse to required file and click Open.  

 

Effects and Animation 
Simulation of weather, animation, light, and water effects enhance realism of the 3D visualization. 

 

Weather Effects (clouds, wind, sky, sun, rain, snow, and 

fog) 

On the Effects tab, in the Weather group, set any of the 

following: sky color, sky texture, dynamic clouds covering, 

wind direction, wind speed, fog intensity, rain intensity, 

and snow intensity. 

Animation Effects (e.g. fire, smoke, explosions).  

1. Effects tab > Animation group, click required effect, 

and then from drop-down menu, select required shape.  

2. In Effect property sheet, set the effect's parameters. 

To modify particle properties such as base image, color, 

size, and lifetime, click Set in the Effect Setting field, 

and then modify required parameters in Particle Editor. 

3. Place effect object in 3D Window by clicking desired 

location.  

Water Effects (river, ocean, waterfall, fountain, pool)  

1. Effects tab > Water group> Water Animation (e.g. fountain, pipe) OR Water Body (e.g. lake, pool), and select 

required effect. Then from drop-down menu, select required shape. 

2. In property sheet, set effect's parameters. To modify particle properties, click Set in the Effect Setting field, and 

then modify required parameters in Particle Editor.  

3. For Water Animation, place effect object in 3D Window by clicking in desired location. 

4. For Water Body, place the polygon points in 3D Window by clicking in at least three locations. Right-click to finish. 

Light Effects  

• Effects tab > Light group> Light Effect, and select required effect. Then place the effect object in the 3D Window by 

clicking in the desired location. 

More about: Adding effect objects to enhance your 3D visualization > 

Additional Capabilities 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Effects.htm
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Loading from SkylineGlobe Server (SGS) 
SkylineGlobe Server is a private cloud solution that provides a comprehensive set of web services for 
publishing, storing, managing and streaming 3D spatial data. SkylineGlobe Server provides streaming 
services for all your spatial data types including terrain (MPT/TBP), map (raster-WMS/WMTS), 
feature (WFS/WFS-T), 3D Mesh (3DML, 3D Cesium tiles), and point cloud (CPT, 3D Cesium tiles).  

Logging In to a SkylineGlobe Server 

1. Top right of application ribbon > Click Log in.  

2. Enter login information > click Log in. 

Loading a Project or Layer 

1. For Project: File menu  > point to Open 

and select Open Project from SkylineGlobe. 

2. For Layer: Layers tab > click Load Layers. 

3. Search for required layer. 

4. Select required layer and click Load. 

Searching SkylineGlobe Server for Layers 

In SkylineGlobe Layers dialog box: 

1. To search for string: In the Search String field, type a search string or enter an attribute, condition, and value and 

click Insert String . 

2. To search according to geographic location: Click Set Bounding Box > select required region by drawing a rectangle 

on the map on the right side of the page. 

3. Click Search.  

Publishing to SkylineGlobe Server (SGS) 
All publishing and uploading of layers and projects to the server can be done directly from 
TerraExplorer. Through a single publishing 
operation, data is made ready for 
consumption for all TerraExplorer clients: 
Desktop, Mobile, and TE for Web.  

Publishing a Project or Layer to SkylineGlobe 

Server  

1. For Project: Home tab > click Publish to SG. 

2. For Layer: In Project Tree, right-click required 

layer > select Upload to SkylineGlobe. 

3. TerraExplorer automatically checks for similar 

layers already on the server. If similar layers 

are found, you can select to Republish or Use 

Existing.  

4. Clear the Use Existing check box for each layer 

you want to republish instead of using copy on 

the server. Then click OK.  

5. Click Publish.  

More about: Working with SkylineGlobe Server > 

SkylineGlobe Server 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Working_with_SkylineGlobe_Server.htm
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Other Publishing Options 
The Publish TerraExplorer Kit process collects all the files that are used in the project and stores 
them in the target directory for distribution to external users using any external storage device r.  

Publishing a Kit 

1. Save project. 

2. Home tab > Click Publish Offline > Select either Publish Project as Local Kit or Extract and Publish Area as Offline 

Kit.  

3. For Publish Project as Local Kit: > In the dialog that 

opens, in Kit field, browse to folder for kit files. 

4. In the Terrain field, select whether to copy the 

terrain database to kit, to keep a link to database, 

or not copy (to save space). 

5. Select the Include TerraExplorer install kit check 

box for user who doesn’t have TE installed > Click 

OK.  

6. For Extract and Publish Area as Offline Kit (Create a directory for offline use that contains the terrain, layers, objects, 

and resources of a selected subset of the TerraExplorer project): > In the dialog that opens, in Kit field, browse to 

folder for kit files. 

7. In the Output Project section of dialog, click Create and mark area of interest by drawing a clip polygon in 3D 

Window. 

8. When updating existing offline kit, if want to accelerate process by skipping terrain and layer extraction for existing 

files, select relevant check boxes. > Click Publish. 

More about: Publishing TerraExplorer projects > 

  

Other Publishing Options 

https://www.skylinesoft.com/KB_Resources/TED/Web%20Help/User%20Guide/About_Publishing_TerraExplorer_Projects.htm
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